[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gcl-devel] Re: tried to make

From: Camm Maguire
Subject: [Gcl-devel] Re: tried to make
Date: 22 Jun 2006 14:01:22 -0400
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2

Greetings!  Apologies for the permissions, there should be an
executable saved_xgcl in there at present in case you want to take a

The basic issue that I've uncovered thus far is that a simple
replacement of int->fixnum will not suffice, as some needed "returns"
are 8 bytes, and some 4 (mostly the latter).  Anything that returns a
window needs to be 8 bytes, whereas most dimensions (x,y,height,etc.)
are 4.  So I have a fixnum-pos in addition to the in-pos at the
moment.  Problems still persist, so if we can parallel process on
this, that would be great.

Thanks again!

P.S.  in xgcl-2, a "make saved_xgcl LISP=../unixport/saved_ansi_gcl"
should work, but the directory should be clean first, i.e. no leftover
gcl-produced c files (gcl_*c, user-init.c, ...).  Sorry this is still
a bit in a state of flux.

Take care,

"Gordon Shaw Novak" <address@hidden> writes:

> Camm,
> I tried to remake the GCL using a copy of your directory, but
> failed.  Lots of things that should be executable were not;
> I changed those manually.  It still didn't work, as shown below.
> Maybe this doesn't matter.
> echo " (in-package \"USER\")(system:save-system \"saved_pre_gcl\")" >>foo
> /home/novak/gcl-2.6.8pre/unixport/raw_pre_gcl 
> /home/novak/gcl-2.6.8pre/unixport/ -libdir /home/novak/gcl-2.6.8pre/ < foo
> GCL (GNU Common Lisp)  April 1994  262144 pages
> Building symbol table for /home/novak/gcl-2.6.8pre/unixport/raw_pre_gcl ..
> Unrecoverable error: Segmentation violation..
> /bin/sh: line 1: 20166 Aborted                 
> /home/novak/gcl-2.6.8pre/unixport/raw_pre_gcl 
> /home/novak/gcl-2.6.8pre/unixport/ -libdir /home/novak/gcl-2.6.8pre/ <foo
> make[1]: *** [saved_pre_gcl] Error 134
> I went ahead and edited general-c.c and gcl_general.lsp on Harper.
> You might try making xgcl on Harper again using these two files
> from /home/novak/ and see if that helps.
> Many thanks, Gordon

Camm Maguire                                            address@hidden
"The earth is but one country, and mankind its citizens."  --  Baha'u'llah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]