[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gcl-devel] I (Still) need help getting GCL to make in Linux

From: jeff
Subject: [Gcl-devel] I (Still) need help getting GCL to make in Linux
Date: Tue, 20 Jun 2006 14:42:29 +0100
User-agent: Internet Messaging Program (IMP) H3 (4.0.4)

I want to use GCL on a Linux system, and I'd appreciate any help.

Actually, "need to use" would be more appropriate at the moment;
but if I can't get GCL to work fairly easily, I'll have to switch
to a different Lisp.  (My Lisp porting skills are much greater
than my C/make/whatever debugging skills these days.)

I sent a couple of messages earlier (see below) but
received no reply.  :(

The problem might be a simple one, because it gives up quite early
on in the "make" process.

Some information:

I believe I'm using a fairly recent version of Fedora.  The
output of "uname -a" is included in the forwarded message.

I cannot do anything as root, and it is unlikely that I can
get anyone else to do anything as root for me either.

I have to get it working as an ordinary user.

----- Forwarded message from address@hidden -----
   Date: Tue, 11 Apr 2006 17:25:14 +0100
   From: address@hidden
Reply-To: address@hidden
Subject: Re: [Gcl-devel] Problem making 2.6.7 on Linux
     To: address@hidden

Looking at this more closely, I see that it seems to be
trying to write to /bin/gcl.

Why is that?

Quoting address@hidden:

I tried to build GCL 2.6.7, but make gave up almost immediately.
Any clues or other help would be appreciated.

uname -a gives:

Linux todday.inf.ed.ac.uk 2.6.12-1.1381_FC3 #1 Fri Oct 21 03:46:55 EDT 2005 i686 i686 i386 GNU/Linux

I tried:


./configure output ends like this:
checking endianness... little
checking for sbrk... yes
checking for randomized sbrk... yes
checking for randomized brk remedy... no
Cannot build with randomized sbrk

make output:

rm -f bin/gcl xbin/gcl
MGCLDIR=`echo  | sed -e 'sX^\([a-z]\):X/\1Xg'` ; \
GCLDIR=`echo ` ; \
make install-command "INSTALL_LIB_DIR=$GCLDIR" "prefix=$GCLDIR" "BINDIR=$MGCLDIR/unixport" make[1]: Entering directory `/amd/nfs/phoenix/disk/ptn005/jeff-home/new/gcl/gcl-2.6.7'
rm -f /bin/gcl
(echo '#!/bin/sh' ; \
echo exec /unixport/ \\ ; \
echo '   -dir' /unixport/ \\ ; \
echo '   -libdir' / \\ ; \
echo '   -eval '\''(setq si::*allow-gzipped-file* t)'\' \\ ;\
! [ -d "" ] || echo '   -eval '\''(setq si::*tk-library* '\"\"')'\' \\;\
echo '     '\"address@hidden" ) > /bin/gcl;
/bin/sh: /bin/gcl: No such file or directory
make[1]: *** [install-command] Error 1
make[1]: Leaving directory `/amd/nfs/phoenix/disk/ptn005/jeff-home/new/gcl/gcl-2.6.7'
make: *** [command] Error 2

-- Jeff

----- End forwarded message -----

reply via email to

[Prev in Thread] Current Thread [Next in Thread]