[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gcl-devel] configuration/installation of gcl 2.6.5

From: Sam Steingold
Subject: [Gcl-devel] configuration/installation of gcl 2.6.5
Date: Mon, 18 Oct 2004 19:15:14 -0400
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/21.3.50 (windows-nt)


I downloaded gcl 2.6.5 (the latest tar ball on gnu.org) and tried the
ANSI mode.

1. --prefix=foo --exec-prefix=bar installs binary files in foo, not bar.

2. no matter what configure options I supplied, "make install" tried to
   access at least some /usr/... directories not writable for me.

3. installation finally failed because some problems with default.el (I
   did not investigate further).  I pointed --enable-emacs-dir=empty-dir
   to avoid /usr/... acess.

4. "gcl --help" produced REPL, not the list of command-line options.

5. (compile-file "clocc") ==> "The source file clocc.lsp is not found."
   but no error

6. (compile-file "clocc.lisp")

Compiling clocc.lisp.
Error in FUNCALL [or a callee]: Cannot expand the SETF form 

Bailing out...

Sam Steingold (http://www.podval.org/~sds) running w2k
<http://www.camera.org> <http://www.iris.org.il> <http://www.memri.org/>
<http://www.mideasttruth.com/> <http://www.honestreporting.com>
Save your burned out bulbs for me, I'm building my own dark room.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]