[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gcl-devel] Re: GCL on Mac Powerbook G4

From: Camm Maguire
Subject: [Gcl-devel] Re: GCL on Mac Powerbook G4
Date: 11 Aug 2003 12:11:45 -0400
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2


Tim Daly  <address@hidden> writes:

> Camm,
> I tried to make GCL on a Mac Powerbook G4 during the ISSAC conference
> without success. It tries to include a couple .h files that do not
> exist on the BSD-based Mac X (and do not exist on the redhat linux
> distribution). 
> Does GCL run on a powerbook? If so, what is the magic incantation?

GCL is fully supported on Debian powerpc, and builds maxima and acl2
there passing all tests.  My understanding is that there is some
'fink' mechanism for running such packages under mac os-X, and if so
this is my recommendation.  You can grab the powerpc deb from 

We have a gcl developer working on a native mac os-X port, but it is
likely that it will not be able to natively relocate .o files at
first, meaning that one cannot load .o files, save-system, and then
find them on re-execution of the image.  This is a little annoying,
but not fatal, as one can build gcl binaries in an alternate fashion
using (compiler::link ...).  Currently, GCL ships maxima and acl2
using this mechanism on 5 Debian platforms, mips(el), alpha, ia64, and

If there is remote ssh access to such a box, I might be able to get a
native build going. 

Take care,

> Tim Daly
> address@hidden
> address@hidden
> =================================================================
> Tim,
> I greatly enjoyed talking to you.  The Rosetta project is admirable. 
> My interest at present is in maxima and axiom (and hence in gcl also).
> During the conference, Gene Cooperman and I tried to make gcl on my 
> Mac Powerbook G4, which runs MacOS 10.2.6, by trying add-defs of BSD 
> and openBSD.  Neither worked.
> Just now back at home, I tried to make gcl under Suse 8.1.  After 
> compiling all the way to init_pari.c, nsocket.c and sfasl.c, make 
> stops with the message:
>        *** No rule to make target `//lib/cfuns-c.o'

This is from axiom's patch to gcl's makefile and said makefile's being
called outside of the axiom make tree, AFAICT.

Take care,

> For axiom, the tarball seems to be the tarred version of the axiom 
> directory for linux, and has no sources to make it anew.
> Please stay in touch.
> Kamal

Camm Maguire                                            address@hidden
"The earth is but one country, and mankind its citizens."  --  Baha'u'llah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]