[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gcl-devel] Re: [Axiom-developer] axiom on cmu cl

From: Camm Maguire
Subject: [Gcl-devel] Re: [Axiom-developer] axiom on cmu cl
Date: 29 Apr 2003 09:52:48 -0400
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2

Greetings!  [ Just a reminder, I'm still away on sabbatical until 6/1,
so correspondence will be somewhat spotty. ]

I just noticed how cmucl handled the in-package issue:

CMU Common Lisp 18d, running on zdvnetz.zdv.Uni-Mainz.DE
Send questions to address@hidden and bug reports to address@hidden
Loaded subsystems:
    Python 1.0, target Intel x86
    CLOS based on PCL version:  September 16 92 PCL (f)
Warning:  Old-style IN-PACKAGE.

It would be rather easy to implement this type of behavior in GCL, at
least for your development work locally, and perhaps enabled by an
environment variable so as to still pass Paul's ansi-cl tests.  I'm
only bringing this up as there were quite a few bug fixes in addition
to the ansi-cl changes in 2.4 -> 2.5.2.  2.4 should be basically
unchanged from Dr. Schelter's (high quality) work with only a few
minimal fixes.  If axiom ever worked on 2.4, it should still, but in
general, I think 2.5.2 is significantly more robust.  I'd be
interested to see if you still get the stack overflow with the newer
version.  Please let me know if you would like to try a simple patch
to package.d along these lines in 2.5.2.

Also, if you could please post a simple (as possible) set of steps
showing the bug, I'd be happy to look at it here under a debugger.

Take care,

root <address@hidden> writes:

> Sorry for the delay in reply. I was away in the real world. 
> Awesome that you got it to compile. I'll look very carefully at what
> you did. I tried expanding every possible value of GCL's memory 
> control and it had no obvious effect. Perhaps I made a mistake and
> I'll repeat the experiment. If that fixes the problem then it is a 
> major breakthru.
> I wonder if you could do me a favor. The way Axiom works with algebra
> is that, during compile, it loads and calls the domain constructor.
> This lives in a file called RING.NRLIB/code.lsp. The domain constructor
> calls another function which is computed once and cached. It looks like:
> (SETQ |Ring;AL| (QUOTE NIL)) 
> (DEFUN |Ring| NIL 
>  (LET (#:G121144) 
>   (COND 
>    (|Ring;AL|) 
>    (T 
>     (SETQ |Ring;AL| (|Ring;|)))))) 
> (DEFUN |Ring;| NIL 
>  (PROG (#1=#:G121142) 
>   (RETURN 
>    (PROG1 
>     (LETT #1# 
>      (|Join| 
>         (|Rng|) 
>         (|Monoid|)
>         (|LeftModule| (QUOTE |$|))
>         (|mkCategory| 
>           (QUOTE |domain|)
>           (QUOTE (((|characteristic| ((|NonNegativeInteger|))) T)
>                   ((|coerce| (|$| (|Integer|))) T)))
>           (QUOTE ((|unitsKnown| T)))
>           (QUOTE ((|Integer|) (|NonNegativeInteger|))) NIL))
>        |Ring|)
>     (SETELT #1# 0 (QUOTE (|Ring|))))))) 
> Could you trace the function |Ring|, run the following compile,
> and send me the console?
> )co coerce
> )lisp (trace '|Ring|)
> )co xpoly )con XPR
> Tim
> address@hidden
> _______________________________________________
> Axiom-developer mailing list
> address@hidden
> http://mail.nongnu.org/mailman/listinfo/axiom-developer

Camm Maguire                                            address@hidden
"The earth is but one country, and mankind its citizens."  --  Baha'u'llah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]