[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gcl-devel] Re: Problem getting GCL working

From: Camm Maguire
Subject: Re: [Gcl-devel] Re: Problem getting GCL working
Date: 23 Apr 2003 08:54:52 -0400
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2


Toby <address@hidden> writes:

> > 
> > Greetings!  I can't find the original article anywhere, and so am
> > unable to comment on the build difficulties.  However, an
> > automatically built fully functional solaris gcl-2.5.2 tarball can be
> > found at:
> > 
> > ftp://ftp.gnu.org/pub/gnu/gcl/cvs/
> > 
> Camm
> I'm the original poster.  I tried the precompiled tarball and
> it was giving me the same problems my compilation gave me.  Anyways,
> I attached the original message I sent in:
> --SNIP--
> My ultimate goal is to compile a package of Maximus so I've been trying to 
> install
> GCL to that end.  I've downloaded the precompiled Solaris package and 
> installed it.
> I've also compiled the program myself and get the same result.
> However, when I try to run the program, it give me the error:
> /usr/local/bin/gcl: C_INCLUDE_PATH=/usr/local/lib/gcl-2.5.2/h:: is not an 
> identifier

OK, this is a quite simple fix.  gcl uses a shell script wrapper
(/usr/bin/gcl) to setup a few environment variables:

export C_INCLUDE_PATH=/fix/s/camm//usr/lib/gcl-2.5.2/h:$C_INCLUDE_PATH

1) your /bin/sh must not be bash, as it doesn't seem to accept this
   syntax.  Just replace with whatever command you use to set a shell
   environment variable on your /bin/sh.  Or, if you have bash, change
   the first line in /usr/bin/gcl to #!/bin/bash

2) The intent of this variable is to let the underlying C compiler
   know where cmpinclude.h is, a requirement for compiling modules
   only if the compiler::*system-p* variable is set.  One has to set
   system-p on some systems when building maxima, but sparc is not one
   of them, so you probably can live without this option. Gcc will
   respect C_INCLUDE_PATH.  While you can probably get something
   similar to work with the native solaris cc, you're sure to have a
   smooth ride if you have gcc in your path.  I can't remember exactly
   now, but I think gcc may be hardcoded into the compiler:*cc*
   variable in the default solaris build at the ftp site.  You can
   obviously change this if you want to experiment with a different C
   compiler.  So in sum, if 'gcc' works at the command prompt, you are
   probably ready to go after tending to 1) with the default solaris
   build.   Using native cc can most likely be made to work, but will
   take more effort.

Take care,

> >From what I can gather, it is looking for the file cmpinclude.h which is 
> >situated in
> that directory (with suitable permissions from what I can gather).  
> Can anyone point out what I'm doing wrong?  It seems fairly obvious I must be 
> missing
> something stupid.
> BTW, Solaris 8 and should be fully patched. 
> Thanks.
> _______________________________________________
> Gcl-devel mailing list
> address@hidden
> http://mail.gnu.org/mailman/listinfo/gcl-devel
> --UNSNIP--
> _______________________________________________
> Gcl-devel mailing list
> address@hidden
> http://mail.gnu.org/mailman/listinfo/gcl-devel

Camm Maguire                                            address@hidden
"The earth is but one country, and mankind its citizens."  --  Baha'u'llah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]