[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gcl-devel] Build failing with --enable-ansi

From: Camm Maguire
Subject: Re: [Gcl-devel] Build failing with --enable-ansi
Date: 13 Jan 2003 14:11:31 -0500

Hi Peter!  

According to the docs, gbc takes one argument.  t to collect
everything, nil to collect just the cells.  In other words, I think
the error is correct, even if there is some legacy code somewhere just
using (gbc).

Take care,

Peter Wood <address@hidden> writes:

> On Mon, Jan 13, 2003 at 09:00:22AM -0500, Camm Maguire wrote:
> > Hi Paul!  Yes, I saw this, and it should now be fixed.  You must have
> > caught the CVS update in between two rapid revisions last night.  My
> > apologies.  
> > 
> > BTW, could either you or Peter elaborate on what is needed for typep,
> > subtypep, and coerce regarding the recent structure test failures?  I
> > tried Peter's experimental fix, but it led to a value stack overflow.
> > 
> > Take care,
> > 
> Hi
> When I tried the latest nfunlink.c patch, my build broke because
> "system::gbc [or a callee] requires more than zero args".  It doesn't,
> of course.  #'si::gbc gets called in my unixport/ansi_cl.lisp, but not
> in the vanilla build.
> I have just confirmed that the same problem exists in CVS (dowloaded
> now):
> >(gbc)
> Error in GBC [or a callee]: GBC [or a callee] requires more than zero 
> arguments.
> Fast links are on: do (use-fast-links nil) for debugging
> Broken at GBC.  Type :H for Help.
>  1 (Abort) Return to top level.
> dbl:>>
> Regards,
> Peter

Camm Maguire                                            address@hidden
"The earth is but one country, and mankind its citizens."  --  Baha'u'llah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]