[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gcl-devel] Re: [Maxima] Maxima GUIs/emacs troubles!

From: C Y
Subject: [Gcl-devel] Re: [Maxima] Maxima GUIs/emacs troubles!
Date: Fri, 15 Feb 2002 08:22:07 -0800 (PST)

--- Camm Maguire <address@hidden> wrote:
> Greetings!
> OK, I take it by your response that 
> 1) You have correctly built gcl-2.5.0 from cvs with readline support,
>    and that 'ldd unixport/saved_gcl' shows the readline library
> linked
>    in. 
> 2) When executing the script front-end to saved_gcl from an xterm,
>    i.e. the 'gcl' script, you see ^OD] with back-arrow, backspace
>    works, and that tab, Alt-b, etc., report similar ascii
>    representations of control characters to the screen.
> 3) Terminal is as described below, which is the same setup I have
>    here, and should work fine.
> 4) For completeness sake, you don't have some old gcl script in your
>    path, and the script you are executing is:
>       #!/bin/sh
>       exec /usr/lib/gcl-2.5.0/unixport/saved_gcl \
>          -dir /usr/lib/gcl-2.5.0/unixport/ \
>          -libdir /usr/lib/gcl-2.5.0/ \
>          -eval '(setq si::*allow-gzipped-file* t)' \
>          -eval '(setq si::*tk-library* "/usr/lib/tk8.2")' \
>          -eval '(si::init-readline)' \
>            "$@"
>       # other options: -load /tmp/foo.o -load jo.lsp -eval "(joe 3)"
> Questions:
> 1) Can anyone else on this list confirm this behavior on a Redhat
> box?
> 2) Can anyone else report a correctly working setup on Redhat or any
>    other Linux system?
> In other words, I cannot reproduce your behavior at all, and I need
> to
> at least here from someone else who can before concluding that it is
> a
> gcl problem as opposed to a local setup problem.
> Thanks for your patience, and report!

Camm, here's what happened to me on a Redhat 7.1 box:  

I grabbed the latest cvs (using the default tree - I didn't specify
2.5.0, since iirc the default is now 2.5) and tried to configure. 
Here's the relevant part of what happened:

./configure |grep readline
checking for main in -lreadline... no

This results in the failure to include readline support.  I was able to
make it work by using the fix someone had suggested earlier - to add
ncurses to the libs linked in on line 1774 of the configure file:

LIBS="-lreadline -lncurses $LIBS"

Then I removed the config.cache file and tried again:

 ./configure |grep readline
checking for main in -lreadline... yes

and readline support worked.


Do You Yahoo!?
Got something to say? Say it better with Yahoo! Video Mail 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]