[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] Issue with internal links

From: Nick Dokos
Subject: Re: [O] Issue with internal links
Date: Thu, 08 Aug 2019 16:54:31 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

"Doyley, Marvin M." <address@hidden> writes:

> * Testing
> * One
> * Two
>    [[*Testing]].   (I also tried [[Testing]] and I got the same error)
> Debugger entered--Lisp error: (void-function org-pass-link-to-system)
>   org-pass-link-to-system("*Testing")
>   run-hook-with-args-until-success(org-pass-link-to-system "*Testing")
>   (if (run-hook-with-args-until-success 'org-open-link-functions path) ....

org-pass-link-to-system is not a function defined by org mode, AFAICT.
The fact that it's the value of the org-open-link-functions hook reinforces
my belief that at some point in the past, you had defined this function
somewhere and you had included it in the hook; perhaps you lost the function
after an upgrade or a disk failure or ... who knows?

The value of org-open-link-functions is nil in my case, so I'd recommend
you try setting it to that:

     (setq org-open-link-functions nil)

and try following the link. If that works to your satisfaction, then
find the place in your init file or customizations file where
org-pass-link-to-system is added to org-open-link-functions and get
rid of it. Then restart emacs.


"There are only two hard problems in computer science: cache
invalidation, naming things, and off-by-one errors." -Martin Fowler

reply via email to

[Prev in Thread] Current Thread [Next in Thread]