[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] Bizarre gnuplot file creation error

From: Lawrence Bottorff
Subject: Re: [O] Bizarre gnuplot file creation error
Date: Tue, 7 Nov 2017 09:42:36 -0500

Still haven't tracked down the exact steps to reproduce this problem, but it happened again recently -- and starting a new emacs from the command line solved it, i.e., my usual daemon-run emacs seems to be "crudding up" somehow.

On Sat, Nov 4, 2017 at 1:05 PM, Lawrence Bottorff <address@hidden> wrote:
Trying the babel gnuplot the other day, I had trouble getting the results to C-c C-c to actually materialize in the place I'd given. Taking the example from the org-mode babel gnuplot page, (changing the location):

#+begin_src gnuplot :exports both :file omnigraphics/omnig10.png

set title "Putting it All Together"

set xlabel "X"
set xrange [-15:15]
set xtics -15,2,15

set ylabel "Y"
set yrange [-15:15]
set ytics -15,2,15

f(x) = sqrt(x - 1) + 1
g(x) = x**3
h(x) = sqrt(-x - 1) + 1

plot f(x) w lp lw 1, g(x) w lp lw 1, h(x) w l lw 1

The system was not creating the png in the given folder. Finally it occurred to me to look in another place where I'd previously been creating org-mode gnuplot pngs -- and there it was! I could do C-c C-c again and again and see new versions of the png being created each time in yesterday's folder, i.e., not the location given with :file. So the :file omnigraphics/omnig10.png was being blown off and org-mode internal had remembered where I'd previously created pngs and kept creating them there. I've tried to recreate this scenario with just the code snippet above -- fresh (non-daemon) emacs processes, changing the :file location each time -- and I've reproduced the problem sometimes. I've combed through my personal init els and it's definitely nothing I'm telling it. Strange. . . .


reply via email to

[Prev in Thread] Current Thread [Next in Thread]