[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] error on make

From: Giri Prashanth
Subject: Re: [O] error on make
Date: Wed, 27 Jul 2016 07:56:45 -0700

Thank you for your response. I have GNU Emacs 24.5.1 (x86_64-apple-darwin13.4.0, NS apple-appkit-1265.21) .
One possibility is that in OS X, there is a default emacs with version 22.1.1. I tried brew update but I think for some reason it is not updated and may cause for this problem.
Is there a way to specify the location of emacs application and site-lisp folder in the config or  Makefile ?
I tried adding path manually in the prefix argument in local.mk but was not sucessful.

Thank you again,

On Tue, Jul 26, 2016 at 11:21 PM, Nicolas Goaziou <address@hidden> wrote:

Giri Prashanth <address@hidden> writes:

> I got the following error while I ran make on latest org-mode code from git
> got from git://orgmode.org/org-mode.git in OS X:
> rm -f
> /Applications/Xcode.app/Contents/Developer/usr/bin/make -C lisp clean
> rm -f org-version.el org-loaddefs.el org-version.elc org-loaddefs.elc
> org-install.elc
> rm -f *.elc
> /Applications/Xcode.app/Contents/Developer/usr/bin/make -C lisp autoloads
> rm -f org-version.el org-loaddefs.el org-version.elc org-loaddefs.elc
> org-install.elc
> org-version: 8.3.5 (release_8.3.5-1027-g04e0bc)
> Loading ~/.emacs.d/org-mode/lisp/org-compat.el (source)...
> Cannot open load file: cl-lib
> make[1]: *** [org-version.el] Error 255
> make: *** [autoloads] Error 2
> Any ideas on how to fix ?

What is your Emacs version? Development branch requires at least Emacs


Nicolas Goaziou

reply via email to

[Prev in Thread] Current Thread [Next in Thread]