[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[O] org-mode habit consistency graph not displaying

From: Brenda J. Butler
Subject: [O] org-mode habit consistency graph not displaying
Date: Thu, 7 Jul 2016 22:57:01 -0400
User-agent: Mutt/1.5.21 (2010-09-15)

I have a question up at stackoverflow:


Here is the content of the question and update:

org-version 8.3.4 (elpa package, 20160530)
emacs 24.4.1 (Debian package, Installed: 24.4+1-4.1~bpo70+1)

When I started using org-mode from elpa, the habit consistency graph
stopped showing. I was using a version of org-mode that comes with
debian before, with emacs 23 and the graph showed.

I'm a beginner in emacs lisp, but anyway I tried stepping through the
org-agenda-list function and found the org-agenda-finalize function
where the org habit graph is supposed to be inserted via the
org-habit-insert-consistency-graphs function. But it skips over that
function, probably because this expression returns false:

    (next-single-property-change (point-min) 'org-habit-p))

At this point, I don't know what to do to make habits show. This is
the first time I've looked at org-mode code, I don't know what the
above test is for.

Help, please?

UPDATE: 2016-06-25. I upgraded the org-mode package to elpa, 20160620
(still org-version 8.3.4). Still have the same behaviour. I am getting
the package from elpa.gnu.org.

UPDATE 2: 2016-07-02: I did try pressing K (for
org-habit-toggle-habits). It didn't change the contents of the buffer
visibly. I also tried refreshing the buffer after typing K. And
repeating the experiment, in case the K put emacs in the wrong mode
the first time.

Thanks for whatever help you can send ...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]