[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] 8.3 hangs

From: Eric Abrahamsen
Subject: Re: [O] 8.3 hangs
Date: Sat, 15 Aug 2015 17:29:41 +0800
User-agent: Gnus/5.130014 (Ma Gnus v0.14) Emacs/25.0.50 (gnu/linux)

Nicolas Goaziou <address@hidden> writes:

> Samuel Wales <address@hidden> writes:
>> i am still getting a lot of hangs in 8.3.  most often, it is when i do
>> a subtree sort.
>> i keep trying element debug mode, but it has magical bug preventing 
>> abilities.
>> org-show-entry is another place where the bug occurs.  it is part of
>> recreating a more folded state after undoing a sort.
>> once it was like
>> Debugger entered--Lisp error: (quit)
>>   org-element--cache-compare
>>   avl-tree--do-delete
>>   avl-tree--do-delete
>>   avl-tree--do-delete
>>   avl-tree--do-delete
>>   avl-tree--do-delete
>>   avl-tree-delete
>>   org-element--cache-process-request
>>   org-element--cache-sync(#<buffer executive.org> 31756)
>>   org-element-at-point()
>>   org-cycle-hide-drawers(children)
>>   org-show-entry()
>> anybody else getting these hangs?
> I don't. However, as explained already, what triggers the hang is
> unimportant. Once cache is corrupted, many actions can trigger a freeze.
> What matters is the root of the corruption.

I still get hangs from time to time, and `kill -12 $(pidof emacs)'
always shows flyspell-mode in the mix. I never get hangs without
flyspell-mode. I think this has been mentioned before, but I don't know
if anyone went any farther with it. I still get hangs!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]