[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] [DEV] Bump Emacs requirement to 24.4?

From: Achim Gratz
Subject: Re: [O] [DEV] Bump Emacs requirement to 24.4?
Date: Sat, 15 Aug 2015 10:45:54 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.0.50 (gnu/linux)

Nicolas Goaziou writes:
> Just to be sure, can we require Emacs 24.4 for development version
> (a.k.a. Org 8.4)? As a data point, Debian stable provides it.

Debian Squeeze LTS or whatever they call it doesn't w/o backports.
RHEL6 doesn't have it w/o epel (RHEL7 has 24.3 IIRC).
RaspberryPi doesn't have it.

I'm still falling over Emacs 22 in various forms and Emacs 23, where it
is standard is not always at the latest version (23.4).

> Also, what is the status of XEmacs support? AFAIU Org 8.3 doesn't build
> on XEmacs but no one is complaining. We may as well drop it and ignore
> most of "org-compat.el".

I've been doing a lot of this compat stuff, but I gave up since I
couldn't get ERT to work on XEmacs.  Org did build (with lots of errors)
until some point and it was at least superficially usable.  The two
XEmacs users on this list have never responded to any requests for
further testing.  So I guess that XEmacs can be considered

If you were hoping to get rid of compat, then have a look at the warnings
on Emacs 25.

+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Factory and User Sound Singles for Waldorf Q+, Q and microQ:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]