[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] [PATCH] Lookup functions for tables

From: Jarmo Hurri
Subject: Re: [O] [PATCH] Lookup functions for tables
Date: Thu, 20 Sep 2012 13:30:10 +0300
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.3 (gnu/linux)

>> I tested the new functions locally, as can be seen from the
>> examples. I also ran make without problems. I am, however, unable to
>> install org from the git version (for some unknown reason), so I was
>> unable to test the final, committed version.
> I can't decode that last part… you installed Org from git with make,
> then made your changes (also in git) and now Org does or doesn't do
> what when you try to install?

Not being able to decode is understandable, because it wasn't very

Yesterday my org installation from git did not work, but today, when I
took a fresh look at the situation, I was able to notice a path problem
which I solved. I now tested the committed version with my changes, and
it works.

A couple of points about the process:

1. Already yesterday I ran make to make sure that org still compiles
   ok. It did, although the used cl function 'position' does give two

2. When I tried to run "make test", it failed because I don't have ERT
   installed. I am running Emacs 23.3.1, which does not include ERT, and
   I could not find a package providing ert.el in the repositories of
   Fedora 16. Because I was running out of time, I decided not to start
   installing ERT manually.

   Today I installed ERT by hand, but "make test" still does not work,
   because the test script runs "emacs -Q" and thus does not load my
   init file (where the directory of ERT is added to path). I don't want
   to make a manually installed ERT system-wide, so I had to skip the



reply via email to

[Prev in Thread] Current Thread [Next in Thread]