[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] Compilation problem

From: Achim Gratz
Subject: Re: [O] Compilation problem
Date: Tue, 18 Sep 2012 22:00:15 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.2 (gnu/linux)

Alan Schmitt writes:
> There was a revert of a commit that fixed it, and I got back to the
> usual state of getting stuck on some test. (I tried finding which test
> is getting stuck, but I don't know how. I just know the last test to
> pass is test-ob-sh/dont-insert-spaces-on-expanded-bodies. Digging a bit
> more the stuck process is running "zsh -i".

Then it certainly is the sh session test and Emacs doesn't know how to
interpret the prompt it gets from zsh and waits indefinately for the
shell to start or zsh tries to do session management, which doesn't work
in emacs' emulated terminal.  This test is a bit fragile, I've seen it
do strange things on windows as well.  If you have that on your system,
use posh as a shell for the invocation of emacs from the makefile, in

EMACS = SHELL=posh /path/to/emacs

Make sure the shell prompt you get ends with "$" and maybe some
whitespace, then emacs should know the shell is active.

+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Factory and User Sound Singles for Waldorf Q+, Q and microQ:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]