[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[O] htmlize doesn't work in --batch mode

From: Dmitri Makarov
Subject: [O] htmlize doesn't work in --batch mode
Date: Tue, 11 Sep 2012 15:16:03 +0200

Hi all,

I'm having a problem with offline exports.
If I run emacs in --batch mode like this

emacs -batch -l ~/.emacs.d/init.el -eval '(org-publish-all)'

it doesn't seem to load the packages installed by the ELPA package manager.
In particular it doesn't load htmlize package and also loads the bundled org
version 7.8.11 whereas I have newer version 7.9.1 installed in packages.

Also, it seems for the new version of org to take over the bundled org
package when I run emacs in normal window mode I have to invoke
(require 'org-install) from after-init-hook like this

(add-hook 'after-init-hook
          (lambda ()
            (load-file "~/.emacs.d/org.el")))

org.el among other things includes (require 'org-install)

If I place (require 'org-install) directly in my init.el,
emacs loads the org package bundled with the emacs installation,
not the one installed by the package manager, probably because
package-initialize is evaluated after init.el has been loaded.

Is this normal?  Did anyone have the same problem?
My emacs version is GNU Emacs 24.2.1.

I hope my questions make sense, as I don't really have much experience with 
emacs package management, and it seems difficult to describe the problem 
I apologize for this is not being an org-mode question, but since many org users
use htmlize, I figure some of them probably want to export their org files
in batch mode, and perhaps they've faced the same issues with packages
in batch mode that I'm having.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]