[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Orgmode] Re: Problems publishing css files

From: Bernt Hansen
Subject: [Orgmode] Re: Problems publishing css files
Date: Wed, 06 Aug 2008 23:50:55 -0400
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.2 (gnu/linux)

Richard G Riley <address@hidden> writes:

> I can org-publish both web-org and web-images with no problem. However
> when I try to publish web-css I get:
> ,----
> | Debugger entered--Lisp error: (error "Wrong type argument: arrayp, nil")
> |   signal(error ("Wrong type argument: arrayp, nil"))
> |   error("%s" "Wrong type argument: arrayp, nil")
> |   byte-code("Â!ˆÃÄÅ        !\"‡" [orig-buff act-on-choice 
> icicle-try-switch-buffer error "%s" error-message-string] 4)
> |   icicle-execute-extended-command()
> |   call-interactively(icicle-execute-extended-command)
> `----
> I can org-publish-current-file with no problem.
> (I have tried it without icicles loaded too). It is only css files (in
> this instance) causing this. Any suggestions on how to debug this? What
> could it be? I have tried without nxhtml loaded too and have ensured the
> only css mode I have in the one that comes with emacs 22.
> org : 6.06b
> emacs : 22.2.1
> Can anyone confirm (using emacs 22) that they can publish css files
> without a problem?

I'm in the process of finally setting up org-publish for some of my
reference information.  I'm converting another system to org and I get a
similar error (but not identical) due to some of my org files that are
not the correct structure.  I was lazy and just renamed my original
*.txt files to *.org and I haven't completed editing them to convert
them to valid org files.  When I try to export with the wrong format I

| Debugger entered--Lisp error: (wrong-type-argument number-or-marker-p nil)
|   1-(nil)
|   (max (point-min) (1- (previous-single-property-change ... ...)))
|   (get-text-property (max (point-min) (1- ...)) (quote target))
|   (or (get-text-property (point) (quote target)) (get-text-property (max ... 
...) (quote target)))
|   (progn (or (get-text-property ... ...) (get-text-property ... ...)))
|   (if (and found (or ... ...)) (progn (or ... ...)))
|   ...

Maybe your problem is some other css file that the web-css project is
picking up?

If I load a problem file then org-publish-current-file fails with the
above error.

I may be completely off-base here... but it's something else to look at.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]