[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Orgmode] can't make org-publish do anything

From: Dan Davison
Subject: [Orgmode] can't make org-publish do anything
Date: Fri, 4 Jul 2008 20:34:13 +0100
User-agent: Mutt/1.5.18 (2008-05-17)

I'm trying to get going with org-publish, but am falling at the first hurdle. I 
can't get it to do anything...

C-h v shows that org-publish-projects-alist has the value

(("website" :base-directory "~/website/" :publishing-directory 
"~/pub_html/website/" :section-numbers nil :table-of-contents nil))

The directory ~/website exists and contains a trivial org syntax file called 
root.org ('* hello' followed by a newline)

The directory ~/pub_html/website exists.

I was expecting org-publish website, and C-c C-e X website (incidentally the X 
is erroneously down as a C in the documentation node 13.3) to result in a file 
called root.html being written to ~/pub_html/website, but that directory 
remains empty, despite repeated invocations of the same commands...

I know I'm being stupid... how, please?



Org-mode version 6.06pre01

I've tried with and without the trailing slashes on the 
base/publishing-directory values, the documentation shows trailing slashes
I've tried manually expanding ~, to no avail. (But I believe ~ should be fine 
as it is)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]