commit-hurd
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[hurd] 83/87: Use a mere weak attribute instead of a weak alias


From: Samuel Thibault
Subject: [hurd] 83/87: Use a mere weak attribute instead of a weak alias
Date: Sun, 09 Nov 2014 11:05:06 +0000

This is an automated email from the git hooks/post-receive script.

sthibault pushed a commit to branch upstream
in repository hurd.

commit bd611d2bbd2a7faa24ce8d3b1a422cebb8f71e8b
Author: Samuel Thibault <address@hidden>
Date:   Mon Nov 3 00:02:52 2014 +0100

    Use a mere weak attribute instead of a weak alias
    
    We don't need to call the original function, so a weak attribute is
    enough.
    
    * libports/dead-name.c (ports_dead_name): Remove weak alias.
    (__ports_dead_name): Rename back to ports_dead_name, but add weak attribute.
---
 libports/dead-name.c | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/libports/dead-name.c b/libports/dead-name.c
index 8c8029f..9363771 100644
--- a/libports/dead-name.c
+++ b/libports/dead-name.c
@@ -21,9 +21,8 @@
 #include "ports.h"
 #include <mach/notify.h>
 
-void
-__ports_dead_name (void *notify, mach_port_t dead_name)
+void __attribute__ ((weak))
+ports_dead_name (void *notify, mach_port_t dead_name)
 {
   ports_interrupt_notified_rpcs (notify, dead_name, MACH_NOTIFY_DEAD_NAME);
 }
-weak_alias (__ports_dead_name, ports_dead_name);

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-hurd/hurd.git



reply via email to

[Prev in Thread] Current Thread [Next in Thread]