[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: possible bug in the fmt egg?

From: Kristian Lein-Mathisen
Subject: Re: possible bug in the fmt egg?
Date: Tue, 28 Dec 2021 23:10:13 +0100

Hi Kurt,

Thank you for reporting that. Looks like it's been fixed upstream now. The egg seems to be at 8.11.2 still, but I guess the fix will reach the egg on next merge/release.


On Sat, Dec 25, 2021, 02:37 T. Kurt Bond <> wrote:
I'll note that SRFI 166 (which seems to have replaced fmt in chibi-scheme 0.10, which I think is Alex Shinn's own scheme) has a issue that seems similar, but not quite the same:

$ chibi-scheme
> (import (srfi 166))
> (show #f (numeric/si 1024))
> (show #f (numeric/si 0))
ERROR in "inexact->exact": exact: not a finite number: +inf.0
> (show #f (numeric/si -1))
ERROR in "floor": invalid type, expected Number: 0.0+0.45479211794728047i

 I suspect the fmt code is related to the SRFI 166 code.  I just tried this with chibi-scheme head, and it has the same result.  I've add an issue on the chibi-scheme github repo:

On Thu, Dec 23, 2021 at 4:51 PM Mario Domenech Goulart <> wrote:
Hi Kristian,

On Mon, 18 Oct 2021 23:27:25 +0200 Kristian Lein-Mathisen <> wrote:

> I'm playing with the fmt egg and I think I've stumbled upon a problem:
> ~> csi -R fmt -P '(fmt #f (num/si 1024))'
> "1Ki"
> ~> csi -R fmt -P '(fmt #f (num/si 0))'
> Error: (log) log of exact 0 is undefined: 0
> klm@pisa ~ [70]> csi -R fmt -P '(fmt #f (num/si -1))'
> Error: (floor) bad argument type - not a real: 0.0+0.453236014182719i
> I couldn't find the upstream repo to report to, so I thought I'd try here.

The upstream repository is the CHICKEN Subversion repository.

You can get a copy of it with:

  $ svn co fmt

The author of fmt is Alex (Cc'ed).

All the best.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]