[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Ccrtp-devel] Demo program "audiotx" dropping RTP packets

From: Federico Montesino Pouzols
Subject: Re: [Ccrtp-devel] Demo program "audiotx" dropping RTP packets
Date: Tue, 18 Mar 2003 20:20:54 +0100
User-agent: Mutt/1.5.3i


On Fri, Mar 14, 2003 at 10:05:14PM +0100, Robert Szelepcsenyi wrote:
> Hi,
> I am trying to assemble a streaming application that would allow me to
> stream live TV broadcasts through a RTSP server. I have set up a Darwin
> Streaming Server on my Linux and configured it to distribute a live
> broadcast that I feed to it via RTP. I tried to feed an "au" file to it
> using the "audiotx" demo program and play the "broadcast" using a RealAudio
> player. I could hear the "broadcast", but it was periodically interrupted.
> When I tried to capture the broadcast using the "audiorx" demo program, I
> got a file of size about half of the original au file. For these reason I
> suspected that "audiotx" was malfunctioning. I tried to use a sniffer, which
> confirmed my suspicion.
> The sample rate of the "au" file is 8000 samples per second. The "audiotx"
> program is set up to send packets of size 160 each 20us, i.e. 50 times a
> second, (50x160 = 8000). However, the sniffer reveals, that each second
> around 27 packets are sent and 23 packets are lost. When I changed the size
> and frequency of the broadcast (i.e. packets of size 1000 each 125us), I get
> about the same loss rate. For some strange reason the program just refuses
> to send any packets for about 1/2 second.

        Um, very strange, I do not see any reason for this to
happen. I would use audiorx and modify it adding calls to
adu->getSeqNum() in order to get a trace of which packets are dropped.

> I have included the output from the sniffer.
> Linux is SuSE 8.1, kernel 2.4.19
> CommonCPP version is 1.08
> ccRTP is version 1.0pre2 (version 0.9 seemed not to know RTPSession)

        Yes, RTPSession was introduced beginning with 1.0pre0; it was
called RTPSocket before. RTPSocket is now an alias for RTPSession.

> Robert Szelepcsenyi

reply via email to

[Prev in Thread] Current Thread [Next in Thread]