[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

AW: textutils2.1 fails NO LONGER to configure on HPUX 10.20 using HP to

From: Jost Martin
Subject: AW: textutils2.1 fails NO LONGER to configure on HPUX 10.20 using HP tools
Date: Fri Nov 29 14:28:42 2002

Hello Jim, hello Bob

here is my summary of the final outcome.
All problems solved, but some curious questions on my part...

> Jost Martin <address@hidden> [2002-11-25 14:55:21 +0100]:
> > 
> > I tried to configure textutils2.1 on HPUX 10.20 with HP tools.
> Jim suggested trying the current coreutils package.  I routinely built
> the textutils package on hpux and it has always built fine.  When you
> say HP tools I hope you mean the HP ANSI C compiler and not the
> bundled 'crippled' compiler.
> > export CC=cc
> > export CXX=aCC
> > export CPPFLAGS="-I/pd/libs/include/"
> > export LDFLAGS=" -L/pd/libs/lib/"
> > export CFLAGS="+DAportable -Aa +O2"
> Since -Aa looks like the ANSI compiler I will assume that.

Yes, surely that's the ANSI-C package.
> > export CXXFLAGS="+DAportable -AA +O2"
> > ./configure -prefix=/pd/text2.1 --without-gcc
> The configure from textutils and the newer coreutils can correctly
> deduce the -Aa compiler flag.  I would not place it here.  In
> particular you probably want '-Ae -D_HPUX_SOURCE' instead of what you
> have.  Better to avoid saying -Aa and let configure choose -Ae
> instead.  This is very likely your problem.

Yes, configure left to its own devices, chooses -Ae but neither 
-D_POSIX_SOURCE nor -D_HPUX_SOURCE. (In fact -D_HPUX_SOURCE already is set when 
you use -Ae; "Requests a compilation in ANSI C mode with HP C extensions. This 
option is the same as specifying -Aa, -D_HPUX_SOURCE, and +e.")

With that (-Ae alone, no other additions) coreutils is successfully build and 

That leaves two problem for me:
How do I tell configure to add the '+DAportable' ?
Drop the '-g' and instead add '+O2'

Jim wrote:
>If you want to add options like +O2, then
>it's better to use AM_CFLAGS.

Is this also an environment var ? (I assume I have to fiddle with autoconf ?)
Where is this documented ?

> > There is one hickup during make check:
> ...
> > FAIL: slink
> Are you perhaps using NFS-mounted disks?

Yes, that was the problem.
I checked with NFS (fail) and without (pass).
(Is there a note on this ? I searched for NFS, but found none)

Thanks your help


reply via email to

[Prev in Thread] Current Thread [Next in Thread]