[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: sanity.sh fails with GNU sh-utils 2.0.x

From: Pavel Roskin
Subject: Re: sanity.sh fails with GNU sh-utils 2.0.x
Date: Wed, 18 Dec 2002 01:51:12 -0500 (EST)

Hello, Jim!

> Using the latest test release (compiled against libc-2.3.1),
> I can't reproduce that problem.  And there haven't been any
> significant changes to expr.c since 2.0.15.  Would you please
> see the same problem using the latest test release?
>   ftp://alpha.gnu.org/gnu/fetish/coreutils-4.5.4.tar.bz2
>   (coreutils is the union of fileutils, textutils, and sh-utils)
> If you *do* reproduce your problem, please let me know whether
> your build used lib/regex.o or not, and include the output of
> running /lib/libc.so.*.

Yes, I can reproduce the problem with coreutils-4.5.4:

$ expr $'a\nb' : $'a.*\nb'

The default is without regex.  I tried --with-included-regex, which caused
regex.o to be included into libfetish.a.  However, it didn't affect the
bug.  The expression above still gives 0.  I'm using glibc-2.2.93 from Red
Hat 8.0.

However, replacing regex.c with an older version fixes the problem:

$ ./expr $'a\nb' : $'a.*\nb'

I have no idea how to identify the revision of GNU regex.  I think if you
compile coreutils-4.5.4 using --with-included-regex you will have the

I tried to upgrade regex.c and regex.h from glibc-2.3.1, and it also fixed
the problem.

regex.c is split into several parts in glibc-2.3.1, but regex.c includes
all of them.  If you decide to upgrade the included regex source, please
make sure to distribute all those parts.

>From glibc NEWS for version 2.3:

* Isamu Hasegawa contributed a completely new and POSIX-conformant
  implementation of regex.

Finally, sanity.sh works with expr from coreutils-4.5.4 with upgraded
regex from glibc-2.3.1.  At least it didn't fail in "version-1" and it's
still running for several minutes as I'm writing this.

Pavel Roskin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]