[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: porting to UNICOS

From: Jim Meyering
Subject: Re: porting to UNICOS
Date: Fri, 17 Aug 2001 08:56:25 +0200
User-agent: Gnus/5.090004 (Oort Gnus v0.04) Emacs/21.0.105

Thanks for the report.

Have you tried (or are you already) using GNU make?
Maybe the problem lies with make rather than the shell.

Does it work if you insert an extra empty line?
I.e., so src/Makefile looks like this:

sleep_LDADD = $(LDADD) -lm  \


If that doesn't work, just remove the backslash
or use bash and/or GNU make.

Wendy Palm <address@hidden> wrote:
> i'm working on updating the port to unicos and i ran
> into a "make" problem with 2.0.11 that didn't exist with 2.0.
> i narrowed it down to this line in the Makefile created after
> configure is run.  this line appears in this form on both
> unicos and linux, linux's linker doesn't have a problem with
> it but unicos' has a fatal error.
> sleep_LDADD = $(LDADD) -lm  \
> obviously it's really a shell problem, because there is just a
> blank line after the backslash, so it should read it as end of
> line, but shell on the cray keeps reading til characters show
> up, so it fills sleep_LDADD as
> "../intl/libintl.a ../lib/libfetish.a    sleep_DEPENDENCIES = 
> ../intl/libintl.a
> ../lib/libfetish.a", which causes the linker to
> search for a file called "sleep_DEPENDENCIES" (which doesn't exist) and
> fail on the "=".
> src/Makefile.an contains the line
> now, @LIB_CLOCK_GETTIME@ @LIB_NANOSLEEP@ are null, hence
> the empty line, right?


> given the chance of "fixing" the shell on the cray any time soon (not likely)
> do you have any idea how i can get around this?  (beyond hand patching the
> makefile after a configure)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]