[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

multi-line field issues

From: Sentinel
Subject: multi-line field issues
Date: Tue, 23 Sep 2008 10:02:36 +0530 (IST)
User-agent: Alpine 1.10 (OSX 962 2008-03-14)


I am writing an app that uses multi-line fields. I noticed 2 things:

a) ML fields do not store newlines. The output is padded to width. Thus while using elsewhere it needs to be worked on.

b) similarly when putting data into an ML field using set_field_buffer, all data was being rejected, until I found this has to do with newlines.

I have worked around both these, by splitting and adding newlines while saving, and removing newlines and padding while setting. Is this the normal practice ?

Is this behaviour likely to be "fixed" in the near future so we don;t have to do the above.

(I am using the latest ncurses on OS X - updated through port install).

btw, as a background, I am writing an application generator using DSL input (domain specific language). It is coming up very well. I will have some questions as I go along.

ruby 1.8.7  | os x 10.5.4 |  vim 7

reply via email to

[Prev in Thread] Current Thread [Next in Thread]