[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

`multiple target patterns' on make...

From: Matthew Percival
Subject: `multiple target patterns' on make...
Date: Mon, 20 Mar 2006 09:14:39 +1100


        I am having trouble trying to compile ncurses.  Indeed, it does not
even begin compiling!  I configure it with:
                ./configure --prefix=/usr/local --build=i686-linux 
                --disable-assumed-color --disable-big-core --disable-ext-funcs
                --disable-home-terminfo --disable-largefile

        Yet, when I run make, I get the following output:
                $ make
                cd man && make DESTDIR="" all
                make[1]: Entering directory `/usr/src/ncurses-5.5/man'
                make[1]: Nothing to be done for `all'.
                make[1]: Leaving directory `/usr/src/ncurses-5.5/man'
                cd include && make DESTDIR="" all
                make[1]: Entering directory `/usr/src/ncurses-5.5/include'
                Makefile:130: *** multiple target patterns.  Stop.
                make[1]: Leaving directory `/usr/src/ncurses-5.5/include'
                make: *** [all] Error 2

        I also get similar `multiple target patterns' errors if I enter
subdirectories directly and execute make.  In every case, the contents
of the line are the same, but I am not sure what to do, and have not
been able to find anything of this problem happening with ncurses
before, so it is obviously not a bug in the package (I have tried with
5.5 and 5.4 too, in case that made any difference).  I have also tried
running configure with no options at all, but still have the same error
when I call make.  I have attached the Makefile in include/ as an
example of what I am getting, in case that helps.

        If anyone has any ideas as to a possible solution for this, I would be
most appreciative of your assistance.

        -- Matthew

Attachment: Makefile
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]