[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-glpk] Assertion at glpipm.c; line 571

From: Barry Rountree
Subject: [Bug-glpk] Assertion at glpipm.c; line 571
Date: Sun, 26 Mar 2006 13:19:45 +0400


I'm using glpk-4.8 (great tool, btw!) and am running into a problem using the 
interior point solver.  The output from the run looks like:

lpx_interior: original LP problem has 4212 rows and 6739 columns
lpx_interior: transformed LP problem has 702 rows and 1402 columns
lpx_interior: A has 2662 non-zeros
lpx_interior: S has 1682 non-zeros (upper triangle)
lpx_interior: minimal degree ordering...
lpx_interior: computing Cholesky factorization...
lpx_interior: U has 1682 non-zeros
lpx_interior: guessing initial point...
Assertion failed: x[j] > 0.0 && z[j] > 0.0; file glpipm.c; line 571

I've tried this on three different datasets and get the same error.  However, 
I have used it before successfully on other datasets, and I'm also dealing 
with some new data processing code, so it's quite possible that my 
application could be stomping on the library.

However, I am curious to know if anyone else has seen this assertion.  If not, 
could characteristics of the data be at fault?

The simplex solver does find the optimal solution, btw, so if I'm doing any 
stack stomping it's very (un)lucky stuff.

Thanks much,

Barry Rountree
Ph.D. Student, Computer Science
University of Georgia
Athens, Georgia, US

reply via email to

[Prev in Thread] Current Thread [Next in Thread]