[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-glpk] Problem in post-solve

From: Andrew Makhorin
Subject: [Bug-glpk] Problem in post-solve
Date: Sat, 4 Oct 2003 17:10:28 +0300

----- Original Message -----
From: Jiøí Spitz <address@hidden>
To: <address@hidden>
Sent: Saturday, October 04, 2003 2:07 PM
Subject: Problem in post-solve


After "glpsol ax000000.mps" I get the message "OPTIMAL SOLUTION FOUND"
followed immediately by the error message "Assertion failed: lpp != lpp;
source/glplpp2.c; line 941".

It seems it is some problem with post-solve procedures because using "glpsol
--nopresol ax000000.mps" the program finishes normally.

The problem occurs in glpk versions 4.0 and 4.1. I tried Linux gcc 3.2.2 and
MinGW compilers with the same result.

I am aware that the LP problem is not very well scaled but I cannot correct
easily because it is generated from DB using a quite complicated model

The problem is nothing cruicial for me but I hope this report helps you to
improve the future releases of this excellent software.

Best regards,

Jiri Spitz

I detached the file ax000000.mps.gz attached to the original message due
to its large size (605 KB, 21788 rows, 25945 columns, 127375 non-zeros).

Andrew Makhorin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]