bug-coreutils
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#21372: [PATCH v4] df: fix prioritize real mounts over bind mounts


From: Dave Chiluk
Subject: bug#21372: [PATCH v4] df: fix prioritize real mounts over bind mounts
Date: Tue, 22 Sep 2015 17:28:17 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.8.0

The patch I just sent out broke existing behavior on non-linux again.
I'm really beginning to hate that if statement.  Anyhow, I fixed that,
and changed it around for readability.

Dave.

On 09/22/2015 05:03 PM, Dave Chiluk wrote:
> I like and appreciate the refactor, but I think the variable name
> "target_nearer_device_root" for the boolean, follows the existing code
> better.  I also fixed the logic to match the new name.
> 
> Dave.
> 
> On 09/21/2015 07:43 PM, Pádraig Brady wrote:
>> On 21/09/15 23:44, Pádraig Brady wrote:
>>> On 21/09/15 21:04, Dave Chiluk wrote:
>>>> Fixes an issue where bind mounts with shorter mount directories than the
>>>> original mount are prioritized when running df.  The root cause of this
>>>> is that /proc/self/mountinfo now lists the filesystem device with bind
>>>> mounts rather than the source directory. With /etc/mtab the source
>>>> device was listed as the originating directory so this was not an issue.
>>>>
>>>> More information is available here.
>>>> https://bugs.launchpad.net/ubuntu/+source/coreutils/+bug/1432871
>>>> ---
>>>>  src/df.c | 9 +++++++--
>>>>  1 file changed, 7 insertions(+), 2 deletions(-)
>>>>
>>>> diff --git a/src/df.c b/src/df.c
>>>> index 2e541b9..4a3afa2 100644
>>>> --- a/src/df.c
>>>> +++ b/src/df.c
>>>> @@ -652,9 +652,14 @@ filter_mount_list (bool devices_only)
>>>>                else if ((strchr (me->me_devname, '/')
>>>>                         /* let "real" devices with '/' in the name win.  */
>>>>                          && ! strchr (devlist->me->me_devname, '/'))
>>>> -                       /* let a shorter mountdir win.  */
>>>> -                       || (strlen (devlist->me->me_mountdir)
>>>> +                       /* let a shorter mountdir win. If it's mntroot is 
>>>> */
>>>> +                       /* also shorter. i.e. not a bind mount. */
>>>> +                       || ((strlen (devlist->me->me_mountdir)
>>>>                             > strlen (me->me_mountdir))
>>>> +                          && (devlist->me->me_mntroot == NULL
>>>> +                             || me->me_mntroot == NULL
>>>> +                             || (strlen (devlist->me->me_mntroot)
>>>> +                                 >= strlen(me->me_mntroot))))
>>>>                         /* let an entry overmounted on a new device win... 
>>>>  */
>>>>                         || (! STREQ (devlist->me->me_devname, 
>>>> me->me_devname)
>>>>                             /* ... but only when matching an existing mnt 
>>>> point,
>>>>
>>>
>>> This logic looks correct thanks.
>>> I'll adjust the comment a bit and maybe refactor
>>> all the conditions to a single nearer_device_root boolean.
>>>
>>> I'll push this later on,
>>> with the associated gnulib update.
>>
>> Attached is the refactored patch,
>> with also lots of adjustments to commit messages.
>> I'll apply tomorrow.
>>
>> thanks,
>> Pádraig.
>>
> 

Attachment: 0001-df-prioritize-mounts-nearer-the-device-root.patch
Description: Text Data


reply via email to

[Prev in Thread] Current Thread [Next in Thread]