In file locale.c, function get_locale_var, locale =
default_locale; /* system-dependent; not really portable. should it
be "C"? */
default_locale contains string returned by calling
setlocale(LC_ALL,NULL); and we then use this string to assign locale for
LC_'every_other' and this is not right way. Why we simple don't call
setlocale(LC_ALL,default_locale)? The final code will be shorter and
more readable...