[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH 00/10] Make recent feature better looking
From: |
Akim Demaille |
Subject: |
[PATCH 00/10] Make recent feature better looking |
Date: |
Tue, 7 Apr 2020 07:13:47 +0200 |
These changes try to make the generated code cuter. And to avoid the
gratuitous "yy" prefix where it is useless (Java has better scoping
than C). And to start documenting.
Akim Demaille (10):
c: make the generated YYSTYPE nicer to read
c: make the token kind definition nicer to read
c: make the symbol kind definition nicer to read
java: style: fix coding style
java: use getExpectedTokens, not yyexpectedTokens
java: rename Lexer.yyreportSyntaxError as reportSyntaxError
java: prefer null to YYSYMBOL_YYEMPTY
java: document new features
skeletons: beware not to use yyarg when it's null
todo: update
README-hacking.md | 7 +-
TODO | 46 +------
data/skeletons/bison.m4 | 19 ++-
data/skeletons/c++.m4 | 14 +--
data/skeletons/c.m4 | 35 +++---
data/skeletons/glr.c | 4 +-
data/skeletons/java.m4 | 4 +-
data/skeletons/lalr1.cc | 3 +-
data/skeletons/lalr1.java | 101 +++++++++-------
data/skeletons/yacc.c | 4 +-
doc/bison.texi | 67 +++++++++++
examples/java/calc/Calc.y | 6 +-
src/parse-gram.c | 207 ++++++++++++++++----------------
src/parse-gram.h | 245 ++++++++++++++++----------------------
tests/local.at | 6 +-
15 files changed, 397 insertions(+), 371 deletions(-)
--
2.26.0
- [PATCH 00/10] Make recent feature better looking,
Akim Demaille <=
- [PATCH 01/10] c: make the generated YYSTYPE nicer to read, Akim Demaille, 2020/04/07
- [PATCH 02/10] c: make the token kind definition nicer to read, Akim Demaille, 2020/04/07
- [PATCH 03/10] c: make the symbol kind definition nicer to read, Akim Demaille, 2020/04/07
- [PATCH 05/10] java: use getExpectedTokens, not yyexpectedTokens, Akim Demaille, 2020/04/07
- [PATCH 04/10] java: style: fix coding style, Akim Demaille, 2020/04/07
- [PATCH 07/10] java: prefer null to YYSYMBOL_YYEMPTY, Akim Demaille, 2020/04/07
- [PATCH 10/10] todo: update, Akim Demaille, 2020/04/07
- [PATCH 06/10] java: rename Lexer.yyreportSyntaxError as reportSyntaxError, Akim Demaille, 2020/04/07
- [PATCH 08/10] java: document new features, Akim Demaille, 2020/04/07
- [PATCH 09/10] skeletons: beware not to use yyarg when it's null, Akim Demaille, 2020/04/07