[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH 0/8] Rename token/symbol type as token/symbol kind
From: |
Akim Demaille |
Subject: |
[PATCH 0/8] Rename token/symbol type as token/symbol kind |
Date: |
Sun, 5 Apr 2020 16:29:55 +0200 |
The implementation of symbol kinds is almost over, I think the
documentation is what mostly needs more work. Then we should be able
to finish the ongoing work on error message and autocompletion
features.
And, well, Bison 3.6 will be in sight.
It will be time to use the beta on several projects to make sure we
match the needs. It will be time to revisit, for instance, the issues
I found in several projects using Bison (see
https://lists.gnu.org/r/bison-patches/2020-01/msg00000.html).
Cheers!
Akim Demaille (8):
c, c++: rename yysymbol_type_t as yysymbol_kind_t
d, java: rename SymbolType as SymbolKind
m4: rename b4_symbol_sid as b4_symbol_kind
m4: we don't need undef_token_number
doc: refer to the token kind rather than the token type
skeletons: use consistently "kind" instead of "type" in the code
bison: use consistently "token kind", not "token type"
regen
NEWS | 18 ++-
TODO | 1 +
data/README.md | 17 ++-
data/skeletons/bison.m4 | 28 ++--
data/skeletons/c++.m4 | 26 ++--
data/skeletons/c.m4 | 28 ++--
data/skeletons/d.m4 | 8 +-
data/skeletons/glr.c | 52 ++++----
data/skeletons/glr.cc | 26 ++--
data/skeletons/java.m4 | 16 +--
data/skeletons/lalr1.cc | 48 +++----
data/skeletons/lalr1.d | 38 +++---
data/skeletons/lalr1.java | 58 ++++----
data/skeletons/yacc.c | 40 +++---
doc/bison.texi | 230 ++++++++++++++++----------------
examples/c++/README.md | 2 +-
examples/c/bistromathic/parse.y | 6 +-
examples/java/calc/Calc.y | 6 +-
src/output.c | 5 +-
src/parse-gram.c | 128 +++++++++---------
src/parse-gram.h | 14 +-
src/parse-gram.y | 4 +-
src/reader.c | 6 +-
src/scan-gram.l | 2 +-
src/tables.c | 2 +-
tests/local.at | 16 +--
26 files changed, 419 insertions(+), 406 deletions(-)
--
2.26.0
- RFC: renaming the symbol "types" as "kinds", Akim Demaille, 2020/04/04
- Re: RFC: renaming the symbol "types" as "kinds", Paul Eggert, 2020/04/04
- Re: RFC: renaming the symbol "types" as "kinds", Akim Demaille, 2020/04/05
- Re: RFC: renaming the symbol "types" as "kinds", Paul Eggert, 2020/04/05
- [PATCH 0/8] Rename token/symbol type as token/symbol kind,
Akim Demaille <=
- [PATCH 4/8] m4: we don't need undef_token_number, Akim Demaille, 2020/04/05
- [PATCH 3/8] m4: rename b4_symbol_sid as b4_symbol_kind, Akim Demaille, 2020/04/05
- [PATCH 7/8] bison: use consistently "token kind", not "token type", Akim Demaille, 2020/04/05
- [PATCH 2/8] d, java: rename SymbolType as SymbolKind, Akim Demaille, 2020/04/05
- [PATCH 6/8] skeletons: use consistently "kind" instead of "type" in the code, Akim Demaille, 2020/04/05
- [PATCH 1/8] c, c++: rename yysymbol_type_t as yysymbol_kind_t, Akim Demaille, 2020/04/05
- [PATCH 8/8] regen, Akim Demaille, 2020/04/05
- [PATCH 5/8] doc: refer to the token kind rather than the token type, Akim Demaille, 2020/04/05