bison-patches
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH 0/9] {master} check more (all?) variables requiring code value


From: Akim Demaille
Subject: [PATCH 0/9] {master} check more (all?) variables requiring code value
Date: Thu, 18 Apr 2013 17:27:59 +0200

I'll push this in a couple of days if there are no comments.

This series of patches was made incrementally while upgrading the
documentation.  I have tried to cover all the variables we use (well,
document), but because we don't have a central point where they are
all defined, it's not so simple.

Actually there is a place where they all should be defined, but the
Java variables are defined in the Java section (which makes sense for
the reader).  I plan to complete the full list of variable names
with those of Java in the near future.

These changes also highlight that we should rename some old variables
that have not been updated, such as parser_class_name, which should
be something like api.parser.name.  There are many variables in Java
that should also be renamed.  I'd be happy to receive help on this
regard, I've never been good at naming (except my sons :).

Akim Demaille (9):
  muscle: check the kind of api.prefix, api.location.type
  regen
  style: use %code for local function declarations in our parser
  style: avoid %{...%} in our parser
  regen
  parser: no longer use the "braceless" non-terminal
  parser: do not convert $ and @ in code values of %define variables
  regen
  muscle: check more cases of %define variables with code values

 data/bison.m4    |   9 +-
 data/c++.m4      |   1 +
 data/java.m4     |  16 +
 doc/bison.texi   | 111 ++++---
 src/location.h   |   4 +
 src/parse-gram.c | 979 ++++++++++++++++++++++++++++---------------------------
 src/parse-gram.h |  43 ++-
 src/parse-gram.y | 216 ++++++------
 src/scan-gram.l  |   6 +-
 tests/calc.at    |  32 +-
 tests/headers.at |   4 +-
 tests/input.at   |  26 +-
 tests/java.at    |  48 +--
 tests/local.at   |  12 +-
 14 files changed, 779 insertions(+), 728 deletions(-)

-- 
1.8.2.1




reply via email to

[Prev in Thread] Current Thread [Next in Thread]