bison-patches
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] Provide an additional sub-message for clarity


From: Akim Demaille
Subject: Re: [PATCH] Provide an additional sub-message for clarity
Date: Wed, 16 Sep 2009 11:51:33 +0200


Le 12 sept. 2009 à 11:19, Alex Rozenman a écrit :

Hi,

I pushed the attached patch to master/branch-2.5. It adds an additional sub-message in case of "invalid references" for clarity. I will submit NEWS
changes as a separate commit (we need to finalize terminology).

Hi Alex,

This is nice, thanks!

+        const char *message = "symbol not found in production";
+
+ complain_at (text_loc, _("invalid reference: %s"), quote (text));
+        if (midrule_rhs_index)
+          complain_at (rule->location, _("  %s before $%d: %.*s"),
+                       message, midrule_rhs_index, len, cp);
+        else
+          complain_at (rule->location, _("  %s: %.*s"),
+                       message, len, cp);

This is not good for internationalization: you don't translate "symbol not found...", and you expect that whatever the language, the full message can be built the same way. This is the kind of things you should not expect, so rather, use two complete internationalized format-strings.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]