bison-patches
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: regression.at


From: Akim Demaille
Subject: Re: regression.at
Date: 18 Sep 2001 16:35:04 +0200
User-agent: Gnus/5.0808 (Gnus v5.8.8) XEmacs/21.4 (Artificial Intelligence)

| --- bison/tests/regression.at Tue Sep 18 15:36:54 2001
| +++ tests-bison/tests/regression.at   Tue Sep 18 15:59:01 2001
| @@ -64,3 +64,25 @@
|  AT_CHECK([bison --defines union.y])
|  
|  AT_CLEANUP([union.*])
| +
| +
| +## --------------------------------------- ##
| +## Duplicate '/' in C comments in %union   ##
| +## --------------------------------------- ##
| +
| +
| +AT_SETUP([%union and C comments])
| +
| +AT_DATA([union-comment.y],
| +[%union      
| +{
| +  /* The int.  */    int   integer;
| +  /* The string.  */ char *string ;
| +}
| +%%
| +exp: {};
| +])
| +
| +AT_CHECK([bison union-comment.y; grep '//\*' union-comment.tab.c], [1], [])

Avoid putting several commands into a single AT_CHECK: you wouldn't
know who failed (worse yet: you wouldn't know if bison failed).

AT_CHECK([bison union-comment.y])
AT_CHECK([grep '//\*' union-comment.tab.c], [1])

is better.  Or `fgrep '//*'', for it is more readable imho.

| +
| +AT_CLEANUP([union-comment.*])
| 
| 
| I have no experience in autotest, so I am not sure if
| my test is written in the right way...

It's fine!  Thanks!



reply via email to

[Prev in Thread] Current Thread [Next in Thread]