[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-libc-dev] [bug #44869] trunk doesn't work with gcc 5.1.0-RC-2015041

From: anonymous
Subject: [avr-libc-dev] [bug #44869] trunk doesn't work with gcc 5.1.0-RC-20150412
Date: Fri, 24 Apr 2015 04:15:38 +0000
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/600.5.17 (KHTML, like Gecko) Version/8.0.5 Safari/600.5.17

Follow-up Comment #3, bug #44869 (project avr-libc):

Having the same problem with gcc 5.1.0 sources as the previous poster. I tried
the latest gcc-6 snapshot (under the assumption that this is what Georg-Johann
means by "avr-gcc 5.2" as I can find no other mention of such a version number
online), and couldn't get it to build (I get a segfault in gen-avr-mmcu-specs,
but that's a bug report for them), so I cannot confirm that this problem is
fixed in a newer version of gcc. System is OS X Yosemite 10.10.3, with most
recent vendor toolchain (based on LLVM 3.6.0svn). Also tried building with
freshly built gcc 5.1.0 as the host compiler instead of LLVM/clang, no

I last successfully compiled avr-gcc and avr-libc on this machine a few months
back with the gcc 4.9.2 sources using LLVM/clang 3.5.0 as the compiler. Sadly,
after the update to LLVM/clang 3.6.0 and what I assume were associated changes
to the system headers, it no longer seems possible to build gcc 4.9.2 either
for the host target or for avr, so I can't roll back to the last good version.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]