[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-libc-dev] [bug #37901] CRC-CCITT calculation incorrect

From: Weddington, Eric
Subject: Re: [avr-libc-dev] [bug #37901] CRC-CCITT calculation incorrect
Date: Tue, 11 Dec 2012 16:34:11 +0000

> -----Original Message-----
> From: address@hidden
> [mailto:address@hidden On
> Behalf Of Erik Walthinsen
> Sent: Tuesday, December 11, 2012 9:20 AM
> To: address@hidden
> Subject: Re: [avr-libc-dev] [bug #37901] CRC-CCITT calculation incorrect
> On 12/11/2012 08:07 AM, Weddington, Eric wrote:
> > Please send ideas for improvement. We're always open-minded, but just
> sticklers for detail (as I'm sure you can tell).
> One option might be to retain the current function solely as #defines,
> but make the *actual* functions strictly defined by their properties:
> __crc16_1021_ffff()
> __crc16_8408_ffff()
> etc.

My only concern is that those names are not particularly mnemonic. :-P I much 
prefer descriptive names for functions, especially for a library.

I would be ok with something like CCITT_little_endian, CCITT_big_endian (note 
these are just examples).

Let's leave the hexadecimal for machine code, if possible. :-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]