[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-libc-dev] [Debian Wheezy] crttn13a.o: No such file?

From: Ivan Shmakov
Subject: [avr-libc-dev] [Debian Wheezy] crttn13a.o: No such file?
Date: Sat, 08 Dec 2012 21:45:03 +0700
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.2 (gnu/linux)

        I've just tried to build a program for ATtiny13A on a recent
        Debian Wheezy, and got:

$ avr-gcc -g -O2 -Wall -pedantic -std=gnu99 -mmcu=attiny13a \
      -L/usr/lib/avr/lib/avr25  ../6pp5iouyw6unnen7egfroozp8b.c \
      -o 6pp5iouyw6unnen7egfroozp8b 
/usr/lib/gcc/avr/4.7.0/../../../avr/bin/ld: crttn13a.o: No such file: No such 
file or directory
collect2: error: ld returned 1 exit status

        Given that earlier builds of ATmega8 code finished successfully,
        I guess that for some reason, avr-gcc (as of gcc-avr 1:4.7.0-2)
        looks for crt*.o only in /usr/lib/avr/lib, while the newer
        AVR Libc (1:1.8.0-2) has them under a bunch of “generation”
        subdirectories.  (This way, this issue may actually affect a
        whole lot of MCU's otherwise supported by AVR Libc.)

        I've also tried gcc-avr from Debian Sid (1:4.7.2-1), but to no

        Now, I'm curious, what's the proper way to fix this issue?

        … Somewhat surprisingly, almost the only mention of the issue I
        was able to find is the following recent remark:

--cut: http://avrfreaks.net/index.php?name=PNphpBB2&file=viewtopic&t=127383 --
    Don't use avr-gcc 4.7.0.  And don't use AVR Libc 1.8.0 or less with
    avr-gcc 4.7.

    Use 4.7.2 with AVR Libc 1.8.1 or higher.  Follow my "News" [1] link
    and read the GCC 4.7 release notes, in particular the caveats

[1] http://gcc.gnu.org/gcc-4.7/changes.html#avr
--cut: http://avrfreaks.net/index.php?name=PNphpBB2&file=viewtopic&t=127383 --

        Which makes me wonder on when exactly AVR Libc 1.8.1 was


FSF associate member #7257

reply via email to

[Prev in Thread] Current Thread [Next in Thread]