avr-libc-dev
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [avr-libc-dev] Re: Request for cbrt() and strdup to be added tolibc


From: Weddington, Eric
Subject: RE: [avr-libc-dev] Re: Request for cbrt() and strdup to be added tolibc
Date: Sun, 22 Jun 2008 14:22:30 -0600

 

> -----Original Message-----
> From: 
> address@hidden 
> [mailto:address@hidden
> org] On Behalf Of Joerg Wunsch
> Sent: Sunday, June 22, 2008 2:09 PM
> To: address@hidden
> Subject: Re: [avr-libc-dev] Re: Request for cbrt() and strdup 
> to be added tolibc
> 
> As Andy H wrote:
> 
> >        if (!copy)
> >                return (copy);
> 
> It would be interesting to see whether the more readable version:
> 
>       if (copy == NULL)
>               return NULL;
> 
> generates the same (or less) code.

Good catch. Regardless whether it generates the same code or not, it
should be compared to NULL anyway because one should never rely on NULL
being zero. Since copy is a pointer, it should be compared to NULL, and
not with a logical NOT operator.

Eric




reply via email to

[Prev in Thread] Current Thread [Next in Thread]