[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-libc-dev] [RFC] Fixing fuse definitions

From: Weddington, Eric
Subject: [avr-libc-dev] [RFC] Fixing fuse definitions
Date: Thu, 3 Jan 2008 18:51:41 -0700

Hi All,

Problem: It seems that some of the new fuse definitions in various IO
header files conflicts with some bit definitions in the same file. This
is for avr-libc 1.6.x. There are 2 bug reports about this, and also
special thanks to Ivan Shmakov for finding out the rest of the name
conflicts in the IO header files.

Potential Solution: After talking to Joerg about this, we're proposing
to change *all* of the fuse definitions in *all* of the IO header files
(where fuse definitions exist, which is most of them) to add a prefix of
FUSE_ to the names. Obviously, this breaks any backwards compatibility.
However, this is for a feature that only *just* released, so it's not
like there is widespread use of this feature. We feel that adding this
prefix will group the fuse definitions better, making it easier to spot
in application code, and also give it's own namespace, so to speak,
which would remove any potential conflict with bit names. No bit names
will be changed, as they have been around a long time.

For users of WinAVR, I have been planning on doing another release in
February (early to mid) anyway, and these new changes would definitely
be incorporated in a new avr-libc release by then and included in that
WinAVR release.

Are there any overwhelming objections? If not, I will be working on
fixing this and committing this soon.

Sorry for any inconvenience.

Eric Weddington

reply via email to

[Prev in Thread] Current Thread [Next in Thread]