[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-libc-dev] Installing avr-libc

From: Martin Justra
Subject: [avr-libc-dev] Installing avr-libc
Date: Mon, 3 Apr 2006 13:46:47 +0200


I tried to install avr-libc-1.4.3.

First I installed binutils 2.15, then gcc-core-4.0.2 and then avr-libc-1.4.3 and uisp.

As soon as I try to compile a project I get the following error:
avr-gcc -g -mmcu=atmega8 -Wall -Wstrict-prototypes -Os -mcall-prologues -o
ddcp.out -Wl,-Map,ddcp.map ddcp.o lcd.o analog.o dac.o kbd.o i2c_avr.o
/usr/local/avr/lib/gcc/avr/4.0.2/../../../../avr/bin/ld: crtm8.o: No such
file: Datei oder Verzeichnis nicht gefunden
make: *** [ddcp.out] Fehler 1

When I copy the crtm8.o in the gcc-Directory I get some errors with eeprom read and so on.

Anybody can help me? Is gcc4 not compatible with the libc?

I used gcc-3.4.2, binutils 2.15 and avr-libc-1.0.5 before but for the new programs theres an error with delay and I tried to update.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]