[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-libc-dev] Simulation of asm files

From: Volkmar Dierkes
Subject: [avr-libc-dev] Simulation of asm files
Date: Wed, 23 Apr 2003 23:19:30 +0200
User-agent: 40tude_Dialog/ Hamster/ Hamster/


on another mailing list I've seen this question (with reply from me
to your information).

> On Wed, 23 Apr 2003 07:08:48 -0000, exnecguy wrote:
>> I have compiled BasicTest1.c with AVRX. When I run the progam in 
>> VMLAB (from www.amctools.com) I am not able to set breakpoints in the 
>> assembly files. I am using winavr.
> I've never used asm files with WinAVR before, but I am using VMLAB
> with success. So I tried a small asm example. I can't set any
> breakpoints or single step into the assembly file. After looking into
> the generated cof file, it seems that the asm stuff isn't included.
> Therefore this must happen with AVRstudio too. Does anyone have
> experience with asm files in WinAVR and simulation?

It seems to me that this is another issue to objtool. If I look into
the elf file (with objtool of course) I can see that my asm file and
the function in it is included. Additional I can find my asm
function in the code. So, compilation seems to be ok for me, but it
is not possible to step into the asm function while simulation.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]