avr-libc-dev
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-libc-dev] [Bug #3184] XCALL resolved incorrectly in avr5/libc.a


From: Joerg Wunsch
Subject: Re: [avr-libc-dev] [Bug #3184] XCALL resolved incorrectly in avr5/libc.a
Date: Fri, 11 Apr 2003 12:07:19 +0200
User-agent: Mutt/1.2.5i

As address@hidden wrote:

> ------------------ Additional Follow-up Comments ----------------------------
> common/macros.inc should use "#if __AVR_MEGA__" instead
> of "#if FLASHEND > 0x2000" - the latter is only defined for
> specific devices (like -mmcu=atmega128), not for -mmcu=avr5.

That probably serves well enough for a short-term solution.  In the
long run, i think we need a more fine-grained ┬╗architecture┬ź model.
Problems noticed so far with our model:

. the library compilation cannot decide whether the device supports
  the ELPM instruction (not all avr5 devices do support it)

. the assembler disallows absolute jump/call instructions for the
  ATmega8 even though this device supports them (but doesn't require
  them -- wouldn't your suggested change even cause absolute jump/call
  to be used on the ATmega8 then?)

. the library cannot decide whether the target device /must/ use
  absolute call/jump (i. e., /this/ bug, #3184)

-- 
J"org Wunsch                                           Unix support engineer
address@hidden        http://www.interface-systems.de/~j/




reply via email to

[Prev in Thread] Current Thread [Next in Thread]