[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-libc-dev] [RFC] make uart interrupt handler names consistent

From: Jason Kyle
Subject: Re: [avr-libc-dev] [RFC] make uart interrupt handler names consistent
Date: Fri, 20 Dec 2002 17:25:42 +1300

At 17:16 19/12/2002 -0800, Theodore A. Roth wrote:

The attached patch make the SIG_UART_* names in the ioXXXX.h files
consistent for all devices. If a device only has one uart, call it uart0.
Uarts and usarts are both called uarts for simplicity.

The hope is that this makes your uart code a bit more portable from one
device to another and will make is easier for the developer to remember
the correct name.

Comments? Objections?


The UART and USART are quite different hardware. The USART can be used in a syncronous mode, which only applies to devices that support it. I struck this naming issue with the iom128.h recently which used UART instead of USART, was going to submit a patch for UART->USART :)

Naming should be as consistent as possible with datasheets so confusion can be avoided. If portability is required between the 2 flavours it can be done in other ways by the programmer.


Jason Kyle

reply via email to

[Prev in Thread] Current Thread [Next in Thread]