[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-libc-dev] eeprom_rb strangeness??

From: Theodore A. Roth
Subject: Re: [avr-libc-dev] eeprom_rb strangeness??
Date: Fri, 1 Nov 2002 10:18:30 -0800 (PST)

On Fri, 1 Nov 2002, E. Weddington wrote:

:) For readability it would be nice to have
:) eeprom_read_byte
:) eeprom_write_byte
:) eeprom_read_word
:) eeprom_write_word
:) eeprom_read_block
:) eeprom_write_block
:) Why would read_block and write_block be spelled out and the others
:) abbreviated? It makes for a non-mnemonically optimal API.

I noticed that already, but didn't want to change the names.

I could implement with the new (spelled out) names and have the old names
be macros to the new while deprecating the old names. This would have the
advantage of the old names (rb, wb, rw) not having the args changed for
backward compatibility.

Ted Roth

reply via email to

[Prev in Thread] Current Thread [Next in Thread]