[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
AM_INCLUDE is a bad name.
From: |
Pavel Roskin |
Subject: |
AM_INCLUDE is a bad name. |
Date: |
Mon, 5 Feb 2001 11:23:25 -0500 (EST) |
Hello, Tom!
I see that you are not using the latest and greatest Autoconf.
Names beginning with AM_ are reserved for macros. Autoconf-2.49c will not
allow such names in configure.
That's why many tests are failing again - AM_INCLUDE is not a good name
for a variable.
How about renaming AM_INCLUDE to AMINCLUDE everywhere? The patch is
attached. It fixes all tests.
Regards,
Pavel Roskin
_______________________________
--- ChangeLog
+++ ChangeLog
@@ -1,3 +1,10 @@
+2001-02-05 Pavel Roskin <address@hidden>
+
+ * automake.in (handle_dependencies): Rename AM_INCLUDE to
+ AMINCLUDE.
+ * m4/make.m4 (AM_MAKE_INCLUDE): Likewise.
+ * tests/exsource.test: Likewise.
+
2001-02-05 Akim Demaille <address@hidden>
* automake.in (handle_texinfo): No longer hard code the clean
--- automake.in
+++ automake.in
@@ -3037,7 +3037,7 @@
$output_rules .= "\n";
foreach $iter (@deplist)
{
- $output_rules .= "address@hidden@address@hidden@ " . $iter .
"\n";
+ $output_rules .= "address@hidden@address@hidden@ " . $iter .
"\n";
}
$output_rules .= &file_contents ('depend');
--- m4/make.m4
+++ m4/make.m4
@@ -10,15 +10,15 @@
END
# If we don't find an include directive, just comment out the code.
AC_MSG_CHECKING([for style of include used by $am_make])
-AM_INCLUDE='#'
+AMINCLUDE='#'
for am_inc in include .include; do
echo "$am_inc confinc" > confmf
if test "`$am_make -f confmf 2> /dev/null`" = "done"; then
- AM_INCLUDE=$am_inc
+ AMINCLUDE=$am_inc
break
fi
done
-AC_SUBST(AM_INCLUDE)
-AC_MSG_RESULT($AM_INCLUDE)
+AC_SUBST(AMINCLUDE)
+AC_MSG_RESULT($AMINCLUDE)
rm -f confinc confmf
])
--- tests/exsource.test
+++ tests/exsource.test
@@ -29,4 +29,4 @@
$AUTOMAKE || exit 1
-grep '@AM_INCLUDE@ .*/xtra\.P' Makefile.in
+grep '@AMINCLUDE@ .*/xtra\.P' Makefile.in
_______________________________
- AM_INCLUDE is a bad name.,
Pavel Roskin <=
- Re: AM_INCLUDE is a bad name., Akim Demaille, 2001/02/05
- Re: AM_INCLUDE is a bad name., Pavel Roskin, 2001/02/05
- Re: AM_INCLUDE is a bad name., Akim Demaille, 2001/02/06
- Re: AM_INCLUDE is a bad name., Alexandre Oliva, 2001/02/06
- Re: AM_INCLUDE is a bad name., Akim Demaille, 2001/02/07
- Re: AM_INCLUDE is a bad name., Alexandre Oliva, 2001/02/07
- Re: AM_INCLUDE is a bad name., Akim Demaille, 2001/02/07
- Re: AM_INCLUDE is a bad name., Pavel Roskin, 2001/02/07
- Re: AM_INCLUDE is a bad name., Tom Tromey, 2001/02/05