[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 1/3] autoreconf: drop support for old (< 1.8) aclocal version
Re: [PATCH 1/3] autoreconf: drop support for old (< 1.8) aclocal versions
Fri, 21 Sep 2012 09:27:13 -0600
Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20120828 Thunderbird/15.0
On 09/21/2012 02:10 AM, Stefano Lattarini wrote:
> The minimal automake and aclocal version required by the "most"
> conservative important real world-projects (like Gnulib and Libvirt)
> is 1.9 anyway (which is the version installed on old but still
> supported installations of stable Distros like RHEL 5), so this
> change should be safe and justified by now.
Concur. 1.9 is still firmly entrenched in active usage, but I rarely
hear about active use of 1.8 or older (even though debian still
distributes them). These days, if you running 'autoreconf' on a machine
that finds it from autoconf 2.69+, either your distro is also new enough
to give you a decent automake by default, or you are experienced enough
to install your own software and can ensure a decent automake. And if
you are on a Debian machine where your dusty-deck package insists on
using older autotools, those wrappers will pick up the correct older
autoreconf that works with the older automake.
> * bin/autoreconf.in (parse_args): Simplify by just assuming the aclocal
> options '--force' and '--no-force' are supported and works correctly.
> ($aclocal_supports_force): Delete, no longer needed.
> (run_aclocal): Heavily simply by assuming that aclocal properly creates
> +++ b/NEWS
> @@ -5,6 +5,8 @@ GNU Autoconf NEWS - User visible changes.
> ** The use of the long-deprecated name 'configure.in' for the autoconf
> input file now elicits a warning in the 'obsolete' category.
> +** Older version of aclocal (< 1.8) are no longer supported by autoreconf.
ACK with those fixes.
Eric Blake address@hidden +1-919-301-3266
Libvirt virtualization library http://libvirt.org
Description: OpenPGP digital signature