autoconf-patches
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: autoconf problem with large files on HP-UX?


From: Jim Meyering
Subject: Re: autoconf problem with large files on HP-UX?
Date: 03 Feb 2001 17:35:27 +0100
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.0.98

I've thought about this some more and am now inclined to
make the simpler, s/9223372036854775807/&ULL/g, change,
because I'm pretty confident that all the compilation environments
that support large files also support the ULL syntax.

Akim Demaille <address@hidden> wrote:
| Jim Meyering <address@hidden> writes:
|
| > I see two ways to fix this:
| >
| >   - assume ULL is accepted by any compiler we care about on any system
| >     with `large file' support.  In that case, the fix is to append
| >     the literal `ULL' to each of the `9223372036854775807's above.
| >
| >   - add a test to accommodate compilers on `large file' systems that
| >     do *not* accept the ULL suffix.
| >
| > Here's a patch that does the latter:
| >
| >     * acspecific.m4 (AC_SYS_LARGEFILE): Use AC_C_ULL.
| >     (_AC_SYS_LARGEFILE_TEST_INCLUDES): Add a parameter, ULL-SUFFIX.
| >     * aclang.m4 (AC_C_ULL): New macro.
| >
| > Of course, if this were to be checked in, there'd also have to be
| > a little bit of documentation for the new macro, AC_C_ULL.
|
| Great :)  Of course, install!
|
| > I should probably remove the `#ifndef __cplusplus';
| > this test shouldn't fail with any C++ compiler,
|
| Why did you put it?

Misguidedly followed the example of AC_C_CONST.

| > and #if directives are _bad_ :-)
|
| Yep, and dangerous :)

If there is consensus that this patch is required, I'll remove it.

| > Index: aclang.m4
| > ===================================================================
| > RCS file: /cvsroot/autoconf/autoconf/aclang.m4,v
| > retrieving revision 1.121
| > diff -u -p -r1.121 aclang.m4
| > --- aclang.m4       2001/01/29 11:54:43     1.121
| > +++ aclang.m4       2001/02/03 10:02:50
| > @@ -1586,6 +1586,26 @@ if test $ac_cv_c_const = no; then
| >  fi
| >  ])# AC_C_CONST
| >
| > +# AC_C_ULL(ACTION-IF-ACCEPTED, ACTION-IF-REJECTED)
| > +# ----------
|
| Please, two lines between macros, and the underlining includes the
| arguments.

Let me make a counter-proposal :-) (only half in jest)
Either provide a way to automate maintaining your lines of `-' signs
or remove them altogether.  Such conventions are fragile (e.g., renaming
a macro requires that someone notice and adjust the length of the --- string.

| > Index: acspecific.m4
| > ===================================================================
| > RCS file: /cvsroot/autoconf/autoconf/acspecific.m4,v
| > retrieving revision 1.333
| > diff -u -p -r1.333 acspecific.m4
| > --- acspecific.m4   2001/01/29 22:36:09     1.333
| > +++ acspecific.m4   2001/02/03 10:02:51
| > @@ -352,11 +352,14 @@ AU_DEFUN([AC_ARG_ARRAY],
| >  with arguments. Remove this warning when you adjust your code.])])
| >
| >
| > -# _AC_SYS_LARGEFILE_TEST_INCLUDES
| > +# _AC_SYS_LARGEFILE_TEST_INCLUDES(ULL-SUFFIX)
| > +# If the compiler allows integer constants with the `ULL' suffix,
| > +# ULL-SUFFIX should be precisely that: ULL.  Otherwise, it must
| > +# be the empty string.
| >  # -------------------------------
|
| Hm, please, place the underlining properly :)

Please reconsider the counter-proposal :-)

| In addition to documentation, may I ask you to complete one of the
| autoscan files?  I mean the mapping from some things to find in C
| source to have autoscan understand it should require AC_C_ULL.

I'm not sure how AC_C_ULL would be used outside the current context,
so don't know if it makes sense to detect whether some arbitrary code
would require the use of the macro.
Hmm... so maybe it should be named _AC_C_ULL.

| Maybe it's not possible, no idea.  But improving the autoscan database
| it an absolute must.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]